Как работать с FreePascal

При запуске окна FreePascal оно имеет небольшие размеры.



Для увеличения размеров консольного окна в Windows кликнем правой кнопкой мыши в заголовок окна и в выпадающем меню выберем пункт "Свойства":



В окне свойств перейдем на закладку "Шрифт" и увидим какие настройки сделаны для консольных окон по умолчанию, а также схематичное отображение как будет выглядеть окно по отношению к экрану монитора (первая стрелка).



Выставим указаные параметры (при необходимости скорректируйте под себя) - схематичное отображение покажет как наше окно будет выглядеть по отношению к экрану, а книзу мы увидим, как будет выглядеть шрифт в нашем окне.



С новыми параметрами окно FreePascal выглядит комфортно больше:



Для создания программы, нужно создать новый файл - Выбираем меню "File -> New".



Составили код программы и обрактив внимание, что по умолчанию наша программа называется noname01.pas. Замечу, что и местом сохранения по умолчанию является каталог компилятора FreePascal, что не сосвсем-то хорошо.



Поэтому выберем своё место расположения файла и дадим программе своё имя файла. Выбираем меню "File -> Save as...".



Внизу окна сохранения указывается путь, в котром FreePascal собирается сохранить файл (изначально это паталог самого компилятора). Сменим каталог, кликая дважды на две точки (или ставим на две точки курсор и нажимаем клавишу Enter на клавиатуре). Так мы будем подниматься вверх по дереву каталогов.



обратите внимание, что две точки для перехода на уровень выше всегда располагаются после всех каталогов текущего уровня:



Остановимся в каталоге C:\FPC\ (чтобы далеко не ходить) и дадим нашему файлу своё название.



Вверху окна с кодом программы мы увидим путь и название нашегой файла.



Для компиляции и выполнения нашей программы выбираем меню "Run -> Run" или на клавиатуре нажимаем комбинацию клавиш Ctrl+F9.



При нахождении ошибок - компилятор выдаст сообщение об ошибке компиляции, А также внизу появится зеленое окно "Compile Messages" со списком найденных в коде программы ошибок.



Выбрав строчку в окне "Compile Messages" с найденной ошибкой и нажав на ней Enter - курсор установится в указанном месте, где компилятор обнаружил ошибку (в нашем случае - 4 строка, 11 символ).



Исправим ошибки - сменим двойные кавычки на одинарные:



и снова выбирем меню "Run -> Run" или на клавиатуре нажмём комбинацию клавиш Ctrl+F9.



При удачной компиляции это окно мелькнет и закроется, программа запустится и исполнится. Мы вернёмся к окну с кодом нашей программы.



Для просмотра результата работы программы необходимо выбрать меню "Debug -> Output"



Нам откроется чёрное окно вывода "User screen", в котором мы увидим результат выполнения нашей программы:



Для переключения с черного окна вывода обратно к окну нашей программы нужно выбрать меню "Window -> Next" или на клавиатуре нажать клавишу F6 (при необходимости несколько раз - это переключение по всем окнам во FreePascal).



Если в тексте (коде) программы производились изменения и они не записаны в файл на диске (т.е. изменения сечас держаться в памяти), то об этом факте нам сигнализирует звёздочка указанная стрелкой на картинке:



Для сохранения изменений в текущем окне необходимо выбрать меню "File -> Save" или на клавиатуре нажать клавишу F2. Программа сохранится в наш файл на диске. Сигнальная звездочка пропадёт.



Чтобы правильно выйти из FreePascal нужно в меню выбрать "File -> Exit" или на клавиатуре нажать комбинацию клавиш Alt+X. FreePascal корректно закроется.



Буфер FreePascal не взаимодействует с буфером операционной системы. Поэтому, чтобы скопировать текст (код) написанной нами программы, нужно найти наш файл с расширением .pas на диске и открыть через блокнот. Идём в каталог (C:\FPC\), в котором мы сохраняли нашу программу:



В нем мы можем увидеть несколько файлов с названием p001. Чтобы точно знать какой файл открывать в блокноте, настроим проводник Windows так, чтобы он показыввал все расширения. Для этого идем по стрелкам на картинке: Упорядочить, затем Параметры папок и поиска.



В открывшемся окне настроек перейдём на закладку Вид и в списке находим опцию "Скравать расширения для зарегистрированных типов". Убираем галочку напротив этой опции. Нажимаем OK.



Видим наш файл с программой p001.pas - нажимаем на нём правую кнопку мыши и в выпадающем контекстном меню выбираем "Открыть с помощью", затем Выбрать программку....



В открывшемся окне "Выбор программы" находим еле заметную кнопочку со стрелкой вниз, которая указана на рисунке большой красной стрелкой.



Раскроются программы для открытия.



Среди программ найдём "Блокнот", выберем её и уберём галочку напротив опции "Использовать выбранную программу для всех файлов такого типа". Далее нажмем "OK".



Наша программа откроется в блокноте.



Из которого мы уже можем скопировать текст программы в буфер Windows оним способом:



...или другим способом:



Скопированный текст мы можем вставить куда угодно, например в форму на сайте, чтобы отправвить текст другу или проверить текст на ошибки в соответсвующем сервисе.

Праздники России

Рейтинг