| sadowod.com | vivaspb.com |
Хочешь улучшить
качество образования -

дай оценку нашей 61 школе!
Рейтинг за 2016 год Подробнее...

Языки программирования (КуМир, Pascal, C, C++)

Оболочки для программирования на представленных языках можно скачать здесь.

Варианты вывода данных на 4-х языках программирования.

КуМир Pascal C C++
алг Куку
нач 
 вывод '2+'
 вывод '2=?', нс
 вывод 'Ответ: 4'
кон
    
program qq;
begin
  write('2+');
  writeln('2=?');
  writeln('Ответ: 4');
end. 
    
#include <stdio.h>
main()
{
   printf("2+");   
   printf("2=?\n");   
   printf("Ответ: 4");
   getchar();
}
    
#include <iostream>
using namespace std;
main()
{
   cout << "2+";   
   cout << "2=?\n";   
   cout << "Ответ: 4";
   cin.get();
}
    
алг Куку
нач 
 вывод '2+'
 вывод '2=?', нс
 вывод 'Ответ: 4'
кон
    
program qq;
begin
  write('2+');
  writeln('2=?');
  writeln('Ответ: 4');
end. 
    
#include <stdio.h>
main()
{
   printf("2+");   
   printf("2=?\n");   
   printf("Ответ: 4");
   getchar();
}
    
#include <iostream>
main()
{
   std::cout << "2+";   
   std::cout << "2=?\n";   
   std::cout << "Ответ: 4";
   std::cin.get();
}
    

Типы переменных

Числа КуМир Pascal C C++
целые цел integer int int
вещественные вещь real float float

Объявление переменных

КуМир Pascal C C++
цел a, b, c var a, b, c: integer; int a, b, c; int a, b, c;

Соответсвия команд языков программирования

КуМир Pascal C C++
вывод a
write ( a );
printf ( "%d", &a );
cout << a;
ввод a
read ( a );
scanf ( "%d", &a );
cin >> a;

команда Pascal C / C++
цикл с параметром
for нач.знач.счётчика to кон.знач.счётчика do
begin операции end;
for ( нач.знач.счётчика ;
условие выполнения ;
шаг.счётчика  )
{ операции };
 
цикл с предусловием
while условие выполнения do
begin операции + счётчик end;
while( условие выполнения )
{ операции + счётчик }
 
цикл с постусловием
repeat операции + счётчик
until условие выхода;
do { операции + счётчик }
while( условие выполнения )
 
ветвление (условие)
[сокращённая форма]
if условие
then действие;
if ( условие )
   { дейтвие }
 
ветвление (условие)
[полная форма]
if условие
then действие 1
else действие 2;
if ( условие )
   { дейтвие 1 }
else
   { дейтвие 2 }
 
ветвление (условие)
[расширенная форма]
 
if ( условие 1 )
   { дейтвие 1 }
else if ( условие 2 )
   { дейтвие 2 }
else if ( условие 3 )
   { дейтвие 3 }
else
   { дейтвие 4 }
 

Сложение чисел

КуМир Pascal C C++
алг Сумма
нач 
  цел a, b, c
  ввод a, b
  c := a + b
  вывод c
кон
    
program Sum;
var a, b, c: integer;
begin
   read ( a, b );
   c := a + b;
   writeln ( c );
end.
    
#include <stdio.h>
main()
{
   int a, b, c;
   scanf( "%d%d", &a, &b );   
   c = a + b;
   printf( "%d", c );
   getchar();
}
    
#include <iostream>
using namespace std;
main()
{
   int a, b, c;   
   cin >> a >> b;   
   c = a + b;
   cout << c;
   cin.get(); cin.get();
}
    
алг Сумма
нач 
  цел a, b, c
  вывод 'Введите два целых числа'
  ввод a, b
  c := a + b
  вывод a, '+', b, '=', c
кон
    
program Sum;
var a, b, c: integer;
begin
   writeln('Введите два целых числа');
   read ( a, b );
   c := a + b;
   writeln ( a, '+', b, '=', c );
end.
    
#include <stdio.h>
main()
{
  int a, b, c;
  printf("Введите два целых числа\n");
  scanf( "%d%d", &a, &b );   
  c = a + b;
  printf( "%d+%d=%d", a, b, c );
}
    
#include <iostream>
using namespace std;
main()
{
  int a, b, c;
  cout << "Введите два целых числа\n";
  cin >> a >> b;   
  c = a + b;
  cout << a << "+" << b << "=" << c;
}
    

Праздники России

Рейтинг